using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[^@]+\.){5,}[^@]+@(?:[^@]+\.)+[^@]+";
string input = @"q.i.n.ghu.im.i.n.g.o.u.r@gmail.com";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}