package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:[^@]+\.){5,}[^@]+@(?:[^@]+\.)+[^@]+`)
var str = `q.i.n.ghu.im.i.n.g.o.u.r@gmail.com`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}