$re = '/^(?:[^@]+\.){5,}[^@]+@(?:[^@]+\.)+[^@]+/';
$str = 'q.i.n.ghu.im.i.n.g.o.u.r@gmail.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);