using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\${\s*(?:\w+|""[^""\\]*(?:\\[^][^""\\]*)*"")(?:\s*[-+\/*]\s*(?:\w+|""[^""\\]*(?:\\[^][^""\\]*)*""))*\s*}";
string input = @"`${i + "" test""} RESULT ${2 + 4} now ${i + ""}"" } hi`";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}