package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\${\s*(?:\w+|"[^"\\]*(?:\\[^][^"\\]*)*")(?:\s*[-+\/*]\s*(?:\w+|"[^"\\]*(?:\\[^][^"\\]*)*"))*\s*}`)
var str = `\`${i + " test"} RESULT ${2 + 4} now ${i + "}" } hi\``
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}