$re = '/\${\s*(?:\w+|"[^"\\\\]*(?:\\\\[^][^"\\\\]*)*")(?:\s*[-+\/*]\s*(?:\w+|"[^"\\\\]*(?:\\\\[^][^"\\\\]*)*"))*\s*}/';
$str = '`${i + " test"} RESULT ${2 + 4} now ${i + "}" } hi`';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);