re = /\${\s*(?:\w+|"[^"\\]*(?:\\[^][^"\\]*)*")(?:\s*[-+\/*]\s*(?:\w+|"[^"\\]*(?:\\[^][^"\\]*)*"))*\s*}/
str = '`${i + " test"} RESULT ${2 + 4} now ${i + "}" } hi`'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end