#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?=\d++[A-Za-z]+[\w@]+|[a-zA-Z]++[\w@]+)[\w@]{2,}"
Local $sString = "Should match:" & @CRLF & _
"" & @CRLF & _
"h1DF346 123FE453 3f3g6hj7j5v3 hasdf@asdf r3 r@" & @CRLF & _
"" & @CRLF & _
"Should not match:" & @CRLF & _
"" & @CRLF & _
"555555 @ hello onlyletters Jan 123@ @@@"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")