$re = '~(?=\d++[A-Za-z]+[\w@]+|[a-zA-Z]++[\w@]+)[\w@]{2,}~';
$str = 'Should match:
h1DF346 123FE453 3f3g6hj7j5v3 hasdf@asdf r3 r@
Should not match:
555555 @ hello onlyletters Jan 123@ @@@';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);