const regex = new RegExp('(?=\\d++[A-Za-z]+[\\w@]+|[a-zA-Z]++[\\w@]+)[\\w@]{2,}', 'g')
const str = `Should match:
h1DF346 123FE453 3f3g6hj7j5v3 hasdf@asdf r3 r@
Should not match:
555555 @ hello onlyletters Jan 123@ @@@`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}