import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=\\d++[A-Za-z]+[\\w@]+|[a-zA-Z]++[\\w@]+)[\\w@]{2,}";
final String string = "Should match:\n\n"
+ "h1DF346 123FE453 3f3g6hj7j5v3 hasdf@asdf r3 r@\n\n"
+ "Should not match:\n\n"
+ "555555 @ hello onlyletters Jan 123@ @@@";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}