#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Start:([\w\n]+)End:"
Local $sString = "Start:" & @CRLF & _
"Apple" & @CRLF & _
"Cat" & @CRLF & _
"Ball" & @CRLF & _
"End:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")