package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Start:([\w\n]+)End:`)
var str = `Start:
Apple
Cat
Ball
End:`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}