const regex = /Start:([\w\n]+)End:/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Start:([\\w\\n]+)End:', '')
const str = `Start:
Apple
Cat
Ball
End:`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}