import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*?[a-z])(?=.*?[A-Z])(?=.*?[0-9])(?=.*?[#$%^&*()\\-_+=\\{\\}[\\]|\\:;\"'<>,.?\\/]).{8,14}$";
final String string = "n0uppercase$\n"
+ "N0LOWERCASE\\\n"
+ "Th|s0nePass\n"
+ "NoSymbolsHere\n"
+ "NoNumbers$orry\n"
+ "AndTh1$One";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}