re = /^(?=.*?[a-z])(?=.*?[A-Z])(?=.*?[0-9])(?=.*?[#$%^&*()\-_+={}[\]|\:;"'<>,.?\/]).{8,14}$/m
str = 'n0uppercase$
N0LOWERCASE\\
Th|s0nePass
NoSymbolsHere
NoNumbers$orry
AndTh1$One'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end