$re = '/^(?=.*?[a-z])(?=.*?[A-Z])(?=.*?[0-9])(?=.*?[#$%^&*()\-_+={}[\]|\:;"\'<>,.?\/]).{8,14}$/m';
$str = 'n0uppercase$
N0LOWERCASE\\
Th|s0nePass
NoSymbolsHere
NoNumbers$orry
AndTh1$One';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);