import re
regex = re.compile(r"^(?=.*?[a-z])(?=.*?[A-Z])(?=.*?[0-9])(?=.*?[#$%^&*()\-_+={}[\]|\:;\"'<>,.?\/]).{8,14}$", flags=re.MULTILINE)
test_str = ("n0uppercase$\n"
"N0LOWERCASE\\\n"
"Th|s0nePass\n"
"NoSymbolsHere\n"
"NoNumbers$orry\n"
"AndTh1$One")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")