using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+\s-\s(.*)";
string input = @"20023la - 100 lt storage cylinder RBA100 - 1120820
20023la - 20023la - 20023la - 100 lt storage cylinder RBA100 - 1120820
20023la - 20023la - 20023la - 100 lt storage cylinder RBA100 - 1120820
ABCD29A - 666 niner niner zero whiskey alpha - 10 - 10 - 99";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}