import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+\\s-\\s(.*)";
final String string = "20023la - 100 lt storage cylinder RBA100 - 1120820\n"
+ "20023la - 20023la - 20023la - 100 lt storage cylinder RBA100 - 1120820\n"
+ "20023la - 20023la - 20023la - 100 lt storage cylinder RBA100 - 1120820\n"
+ "ABCD29A - 666 niner niner zero whiskey alpha - 10 - 10 - 99";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}