use strict;
my $str = '20023la - 100 lt storage cylinder RBA100 - 1120820
20023la - 20023la - 20023la - 100 lt storage cylinder RBA100 - 1120820
20023la - 20023la - 20023la - 100 lt storage cylinder RBA100 - 1120820
ABCD29A - 666 niner niner zero whiskey alpha - 10 - 10 - 99';
my $regex = qr/\w+\s-\s(.*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}