import Foundation
let pattern = #"\w+\s-\s(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
20023la - 100 lt storage cylinder RBA100 - 1120820
20023la - 20023la - 20023la - 100 lt storage cylinder RBA100 - 1120820
20023la - 20023la - 20023la - 100 lt storage cylinder RBA100 - 1120820
ABCD29A - 666 niner niner zero whiskey alpha - 10 - 10 - 99
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)