const regex = /Google ID: ([^ ]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Google ID: ([^ ]+)', '')
const str = `Short Name: Coin Dozer – World Tour Google ID: com.gamecircus.CoinDozerWorld Version: 3.6 File size: 19.31 MB Category: Games, Casino`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}