use strict;
my $str = '2013-14 SEASON:
Appeared in 81 games (all starts) in his second NBA season in Detroit, averaged 13.5 points, 13.2 rebounds, 1.2 steals and 1.6 blocks in 32.3 minutes';
my $regex = qr/([0-9A-Z-: ]+\n)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}