// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([0-9A-Z-: ]+\n)").unwrap();
let string = "2013-14 SEASON:
Appeared in 81 games (all starts) in his second NBA season in Detroit, averaged 13.5 points, 13.2 rebounds, 1.2 steals and 1.6 blocks in 32.3 minutes";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}