import Foundation
let pattern = #"([0-9A-Z-: ]+\n)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
2013-14 SEASON:
Appeared in 81 games (all starts) in his second NBA season in Detroit, averaged 13.5 points, 13.2 rebounds, 1.2 steals and 1.6 blocks in 32.3 minutes
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}