#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Caín Daniel Romano Sánchez 35 Masculino (Ecuador) San Pablo de Manta."
Local $sString = "Caín Daniel Romano Sánchez 35 Masculino Ecuador San Pablo de Manta" & @CRLF & _
"Darío Cristiano Hernandez Martinez 15 Masculino Bolivia Sacaba" & @CRLF & _
"Emily Alessia Bianco Sutori 15 Femenino Francia Burdeos" & @CRLF & _
"Luis Hilario Hamasaki Schneider 57 Masculino Francia Arles" & @CRLF & _
"Valentin Roberto Rodriguez Rinaldi 43 Masculino Ecuador Santiago de Guayaquil" & @CRLF & _
"Ruby Olivia Johnson Gutierrez 38 Femenino Bolivia Sucre" & @CRLF & _
"Khushi Florence López Messina 50 Femenino Francia París" & @CRLF & _
"Tiburcio Pacifico Feraud Brown 23 Masculino Brasil Rio de Janeiro" & @CRLF & _
"Carla Martina Santoro Fernandez 9 Femenino Bolivia Guayaramerín" & @CRLF & _
"Emma Antonella Williams Himura 43 Femenino Ecuador San Pedro de Riobamba" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")