use strict;
my $str = 'Caín Daniel Romano Sánchez 35 Masculino Ecuador San Pablo de Manta
Darío Cristiano Hernandez Martinez 15 Masculino Bolivia Sacaba
Emily Alessia Bianco Sutori 15 Femenino Francia Burdeos
Luis Hilario Hamasaki Schneider 57 Masculino Francia Arles
Valentin Roberto Rodriguez Rinaldi 43 Masculino Ecuador Santiago de Guayaquil
Ruby Olivia Johnson Gutierrez 38 Femenino Bolivia Sucre
Khushi Florence López Messina 50 Femenino Francia París
Tiburcio Pacifico Feraud Brown 23 Masculino Brasil Rio de Janeiro
Carla Martina Santoro Fernandez 9 Femenino Bolivia Guayaramerín
Emma Antonella Williams Himura 43 Femenino Ecuador San Pedro de Riobamba
';
my $regex = qr/^Caín Daniel Romano Sánchez 35 Masculino (Ecuador) San Pablo de Manta./mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}