import re
regex = re.compile(r"^Caín Daniel Romano Sánchez 35 Masculino (Ecuador) San Pablo de Manta.", flags=re.MULTILINE)
test_str = ("Caín Daniel Romano Sánchez 35 Masculino Ecuador San Pablo de Manta\n"
"Darío Cristiano Hernandez Martinez 15 Masculino Bolivia Sacaba\n"
"Emily Alessia Bianco Sutori 15 Femenino Francia Burdeos\n"
"Luis Hilario Hamasaki Schneider 57 Masculino Francia Arles\n"
"Valentin Roberto Rodriguez Rinaldi 43 Masculino Ecuador Santiago de Guayaquil\n"
"Ruby Olivia Johnson Gutierrez 38 Femenino Bolivia Sucre\n"
"Khushi Florence López Messina 50 Femenino Francia París\n"
"Tiburcio Pacifico Feraud Brown 23 Masculino Brasil Rio de Janeiro\n"
"Carla Martina Santoro Fernandez 9 Femenino Bolivia Guayaramerín\n"
"Emma Antonella Williams Himura 43 Femenino Ecuador San Pedro de Riobamba\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")