using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<tr class=?R3?>(.*?)<\/TR>";
string input = @"<TR CLASS=R3>
<TD CLASS=""R3C15"" ROWSPAN=12 ALIGN=LEFT VALIGN=TOP STYLE=""padding-left: 0""><IMG SRC = ""2 кв._files\image000.png"" ALT = "" width = 153 height = 142 style = ""margin-left:5pt;margin-top:2pt;""></TD>
<TD><DIV STYLE=""position:relative; height:9px;width: 100%; overflow:hidden;""><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=""position:relative; height:9px;width: 100%; overflow:hidden;""><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=""position:relative; height:9px;width: 100%; overflow:hidden;""><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=""position:relative; height:9px;width: 100%; overflow:hidden;""><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=""position:relative; height:9px;width: 100%; overflow:hidden;""><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=""position:relative; height:9px;width: 100%; overflow:hidden;""><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=""position:relative; height:9px;width: 100%; overflow:hidden;""><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=""position:relative; height:9px;width: 100%; overflow:hidden;""><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=""position:relative; height:9px;width: 100%; overflow:hidden;""><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=""position:relative; height:9px;width: 100%; overflow:hidden;""><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=""position:relative; height:9px;width: 100%; overflow:hidden;""><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=""position:relative; height:9px;width: 100%; overflow:hidden;""><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=""position:relative; height:9px;width: 100%; overflow:hidden;""><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=""position:relative; height:9px;width: 100%; overflow:hidden;""><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=""position:relative; height:9px;width: 100%; overflow:hidden;""><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=""position:relative; height:9px;width: 100%; overflow:hidden;""><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=""width:100%;height:9px;overflow:hidden;""> </DIV></TD>
</TR>
";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}