// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)<tr class=?R3?>(.*?)<\/TR>").unwrap();
let string = "<TR CLASS=R3>
<TD CLASS=\"R3C15\" ROWSPAN=12 ALIGN=LEFT VALIGN=TOP STYLE=\"padding-left: 0\"><IMG SRC = \"2 кв._files\\image000.png\" ALT = \"\" width = 153 height = 142 style = \"margin-left:5pt;margin-top:2pt;\"></TD>
<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>
<TD><DIV STYLE=\"width:100%;height:9px;overflow:hidden;\"> </DIV></TD>
</TR>
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}