import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<tr class=?R3?>(.*?)<\\/TR>";
final String string = "<TR CLASS=R3>\n"
+ "<TD CLASS=\"R3C15\" ROWSPAN=12 ALIGN=LEFT VALIGN=TOP STYLE=\"padding-left: 0\"><IMG SRC = \"2 кв._files\\image000.png\" ALT = \"\" width = 153 height = 142 style = \"margin-left:5pt;margin-top:2pt;\"></TD>\n"
+ "<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
+ "<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
+ "<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
+ "<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
+ "<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
+ "<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
+ "<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
+ "<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
+ "<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
+ "<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
+ "<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
+ "<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
+ "<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
+ "<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
+ "<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
+ "<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
+ "<TD><DIV STYLE=\"width:100%;height:9px;overflow:hidden;\"> </DIV></TD>\n"
+ "</TR>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}