# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<tr class=?R3?>(.*?)<\/TR>"
test_str = ("<TR CLASS=R3>\n"
"<TD CLASS=\"R3C15\" ROWSPAN=12 ALIGN=LEFT VALIGN=TOP STYLE=\"padding-left: 0\"><IMG SRC = \"2 кв._files\\image000.png\" ALT = \"\" width = 153 height = 142 style = \"margin-left:5pt;margin-top:2pt;\"></TD>\n"
"<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
"<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
"<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
"<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
"<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
"<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
"<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
"<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
"<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
"<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
"<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
"<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
"<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
"<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
"<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
"<TD><DIV STYLE=\"position:relative; height:9px;width: 100%; overflow:hidden;\"><SPAN></SPAN></DIV></TD>\n"
"<TD><DIV STYLE=\"width:100%;height:9px;overflow:hidden;\"> </DIV></TD>\n"
"</TR>\n")
matches = re.search(regex, test_str, re.IGNORECASE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.