using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\/#@]\w+|'[\s\w]+')";
string input = @"""/create #channel 'name' 'description of the channel' #field1 #field2 @Tushar""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}