$re = '/([\/#@]\w+|\'[\s\w]+\')/';
$str = '"/create #channel \'name\' \'description of the channel\' #field1 #field2 @Tushar"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);