re = /([\/#@]\w+|'[\s\w]+')/
str = '"/create #channel \'name\' \'description of the channel\' #field1 #field2 @Tushar"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end