package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\/#@]\w+|'[\s\w]+')`)
var str = `"/create #channel 'name' 'description of the channel' #field1 #field2 @Tushar"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}