#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s).*?(<a.*?<\/a>).*"
Local $sString = "<body>" & @CRLF & _
" <div>" & @CRLF & _
" <a id="123">text_url</a>" & @CRLF & _
" </div> " & @CRLF & _
"<body>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")