$re = '/.*?(<a.*?<\/a>).*/s';
$str = '<body>
<div>
<a id="123">text_url</a>
</div>
<body>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);