package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s).*?(<a.*?<\/a>).*`)
var str = `<body>
<div>
<a id="123">text_url</a>
</div>
<body>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}