re = /.*?(<a.*?<\/a>).*/
str = '<body>
<div>
<a id="123">text_url</a>
</div>
<body>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end