# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[{](.+?)[}]|(\w+)//g;t' <<< "Alpha Beta C D {e f g} H I {j k l}
"