import re
regex = re.compile(r"^(?![0-9a-zA-Z]+:[0-9a-zA-Z]+$).*$\R*", flags=re.MULTILINE)
test_str = ("local06:local16\n"
"TEXT local76:local16\n"
"local06:local17\n"
"local06:local19\n\n"
"More TEXT local76:local678")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)