re = /^(?![0-9a-zA-Z]+:[0-9a-zA-Z]+$).*$\R*/m
str = 'local06:local16
TEXT local76:local16
local06:local17
local06:local19
More TEXT local76:local678'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result