using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"I(?:[^\w\n]+\w+){0,5}[^\w\n]+(?:TV|chocolate|fire)";
string input = @"I wish a TV
I want some chocolate
I need fire";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}