// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)I(?:[^\w\n]+\w+){0,5}[^\w\n]+(?:TV|chocolate|fire)").unwrap();
let string = "I wish a TV
I want some chocolate
I need fire";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}