re = /I(?:[^\w\n]+\w+){0,5}[^\w\n]+(?:TV|chocolate|fire)/m
str = 'I wish a TV
I want some chocolate
I need fire'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end