package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)I(?:[^\w\n]+\w+){0,5}[^\w\n]+(?:TV|chocolate|fire)`)
var str = `I wish a TV
I want some chocolate
I need fire`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}