const regex = /(?:switch\s*\((?P<conditional>(?:(?:(?:"(?:(?:\\")|[^"])*")|(?:'(?:(?:\\')|[^'])*'))|[^\(\)]|\((?1)\))*)\)\s*{)*(?:(?:\s*(?:case(?P<value>.*?):?\s*{(?P<body>(?:(?:(?:"(?:(?:\\")|[^"])*")|(?:'(?:(?:\\')|[^'])*'))|[^{}]|{(?2)})*)\s*}))+?)|(?:default:\s*{(?P<default_body>(?:(?:(?:"(?:(?:\\")|[^"])*")|(?:'(?:(?:\\')|[^'])*'))|[^{}]|{(?1)})*)\s*}\s*)?}/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:switch\\s*\\((?P<conditional>(?:(?:(?:"(?:(?:\\\\")|[^"])*")|(?:\'(?:(?:\\\\\')|[^\'])*\'))|[^\\(\\)]|\\((?1)\\))*)\\)\\s*{)*(?:(?:\\s*(?:case(?P<value>.*?):?\\s*{(?P<body>(?:(?:(?:"(?:(?:\\\\")|[^"])*")|(?:\'(?:(?:\\\\\')|[^\'])*\'))|[^{}]|{(?2)})*)\\s*}))+?)|(?:default:\\s*{(?P<default_body>(?:(?:(?:"(?:(?:\\\\")|[^"])*")|(?:\'(?:(?:\\\\\')|[^\'])*\'))|[^{}]|{(?1)})*)\\s*}\\s*)?}', 'img')
const str = `switch (count + t - (fdg + fsd))
{
case 1:
{
яячсячсячс ываы
break;
}
case 2:
{
cout << a << " - " << b << " = " << a - b << endl; // выполнить вычитание
break;
}
case 3:
{
cout << a << " * " << b << " = " << a * b << endl; // выполнить умножение
break;
}
case 4:
{
cout << a << " / " << b << " = " << a / b << endl; // выполнить деление
break;
}
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}