import re
regex = re.compile(r"(?:switch\s*\((?P<conditional>(?:(?:(?:\"(?:(?:\\\")|[^\"])*\")|(?:'(?:(?:\\')|[^'])*'))|[^\(\)]|\((?1)\))*)\)\s*{)*(?:(?:\s*(?:case(?P<value>.*?):?\s*{(?P<body>(?:(?:(?:\"(?:(?:\\\")|[^\"])*\")|(?:'(?:(?:\\')|[^'])*'))|[^{}]|{(?2)})*)\s*}))+?)|(?:default:\s*{(?P<default_body>(?:(?:(?:\"(?:(?:\\\")|[^\"])*\")|(?:'(?:(?:\\')|[^'])*'))|[^{}]|{(?1)})*)\s*}\s*)?}", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("switch (count + t - (fdg + fsd)) \n"
"{\n"
" case 1: \n"
" {\n"
" яячсячсячс ываы\n"
" break;\n"
" }\n"
" case 2: \n"
" {\n"
" cout << a << \" - \" << b << \" = \" << a - b << endl; // выполнить вычитание\n"
" break;\n"
" }\n"
" case 3: \n"
" {\n"
" cout << a << \" * \" << b << \" = \" << a * b << endl; // выполнить умножение\n"
" break;\n"
" }\n"
" case 4: \n"
" {\n"
" cout << a << \" / \" << b << \" = \" << a / b << endl; // выполнить деление\n"
" break;\n"
" }\n"
" }")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")